MSSQL 由于执行触发器,登录名xxx的登录失败

郑鹏飞3年前爱T1138

由于编写了服务器级别的触发器,执行触发器时发生了错误导致。

刚才想实现一个服务器级别的登录触发器,结果由于触发器没写好,导致登录任何帐号都失败。

差点就需要重装服务器了!

解决办法:

以最小模式启动MS SQLSERVER,详细步骤如下:

1680704753462.jpg

找到它,打开后:image.png

在高级-启动参数里加上 ";-f;-m"两个参数:

image.png

然后重新启动SQL SERVER实例。

此时,就需要您的运气了。如果你的错误的触发器里带了 with 'sa'这样的参数启动,这时候您必须要记得sa的密码,否则,我也不知道怎么办!因为当您用任何其它的管理员帐号登录,都会提示“用户xxx登录失败。原因:服务器处于单用户模式。目前只有一位管理员能够连接。”。

我一般只用我自己的帐户登录,sa密码早就不知道丢哪去了。。。。(幸运的是我在桌面上保存了)

然后,我就一直用我自己的帐户登录,都没法登录。

在我快要崩溃的时候,都要准备去重装数据库的时候,幸运的是,我在服务器桌面上竟然保存了我的sa密码,而且这个密码竟然是没有被我在某个时候改掉的!


但是,此时还没完,因为我也不知道是哪里设置不对,导致用sa登录时,还是提示错误,大概的意思是“sa已登录,但由于什么共享内存什么的。。。错误”,由于当时心情不好,也没截图,现在也不敢再试了,所以这里没图。

由于登录时还是出现错误,导致没法从服务器管理界面里找到触发器进行禁用。

此时,在不登录的情况下,直接点“新建查询”,会弹出来一个登录,此时幸运的话,可以弹出来一个已经登录了sa帐号的新建查询的窗口。

image.png

输入以下命令:

disable trigger all on all server;

运行,提示运行成功!

成功禁止了过后,再把服务器管理器里的 ;-f;-m 两个参数去掉,重启实例后,就可以成功登录了!


网上还有另外一种解决办法,不过我没试:

可以使用SQLSERVER的专用管理员连接(DAC)连接进服务器,并把触发器先删除掉


我是郑鹏飞。 如果您觉得我的文章对您有帮助,可以点击站点上的 关于站点/支持和帮助
转载请注明 : 文章转载自不了阁-飞哥 blog.forbs.cn
本站文章除注明转载/出处外,均为本站原创或翻译。若要转载务必注明出处,尊重他人劳动成果共创和谐网络环境。

相关文章

多域名的同一个网站,需要部署https,教你如何只用一个SSL证书即可完成部署,且不提示不安全的连接信息。URL重写(重定向插件IIS Write)的使用与规则设置方法

多域名的同一个网站,需要部署https,教你如何只用一个SSL证书即可完成部署,且不提示不安全的连接信息。URL重写(重定向插件IIS Write)的使用与规则设置方法

比如我的网站,我同时申请了两个域名vxmat.cn和vxmat.com,我需要实现1、两个域名都访问同一个网站;2、同时支持带www和不带www的访问;3、必须部署https,当用户以http方式访问...

wsl中每个linux的根目录位置,直接从Windows里访问,直接拷贝文件

wsl中每个linux的根目录位置,直接从Windows里访问,直接拷贝文件

wsl的主系统目录在\\wsl.localhost\,或者是打开我的电脑,向上到桌面,就可以看到。直接在桌面上好像看不到Linux这个系统目录。打开成功后,可以看到每一个已安装的linux子系统的名字...

如何使用VxTerm进行网络设备登录管理

如何使用VxTerm进行网络设备登录管理

咱们一般做设备,如安全设备、路由网关、交换机、服务器等运维管理时,一般都需要用到一个叫做SSH工具、Telnet工具的,下载一个VxTerm,就可以实现。软件地址:https://download.c...

拒绝了对对象 'sp_OACreate' (数据库 'mssqlsystemresource',架构 'sys')的 EXECUTE 权限。

拒绝了对对象 'sp_OACreate' (数据库 'mssqlsystemresource',架构 'sys')的 EXECUTE 权限。

    有个接口,我采用了MSSQL的存储过程执行时使用ServerXMLHTTP直接访问WebService接口的WSDL,直接在MSSQL里就可以使用SOAP协议访问接口,何必...

检查 RichTextBox ScrollBar thumb 是否在滚动条的底部

检查 RichTextBox ScrollBar thumb 是否在滚动条的底部

Imports System.Runtime.InteropServices Public Class jMyBox    &nbs...

一是真懒了,二是真以为理所当然,所以就闹了个小乌龙!-记之前配置多域名多张SSL证书配置不成功

一是真懒了,二是真以为理所当然,所以就闹了个小乌龙!-记之前配置多域名多张SSL证书配置不成功

在配置本站的时候,也不知道是哪里没配置对,导致无法成功的在blog.forbs.cn:443端口上配置SSL证书,因为会提示冲突之类的,然后也确实有搜到文章说SSL证书是认端口的,所以就理所当然的就认...

发表评论    

◎欢迎参与讨论,请在这里发表您的看法、交流您的观点。